Skupos Sync is currently compatible with:

Point of Sale System

  • Verifone POS (Ruby, Ruby II, Ruby CI, or Topaz) with Commander or Sapphire unit.
  • Gilbarco Passport 
  • NCR Radiant/RPOS
  • Clover 

Back office computer & Other Hardware

  • A scanner integrated with your POS.
  • A Windows computer (desktop, laptop, tablet) running Windows 7 or higher
  • Router (or V950 for Sapphire)
  • USB-to-Ethernet adapter (If computer doesn’t have a free ethernet port) 
  • One ethernet cable (Unless you're using a hardwire connection, you'll need an extra cable to connect to the router)

Operating System

Microsoft Windows 7, 8, or 10

At this time, Sync is not compatible with Apple OS, Windows Vista, or Windows XP.

How do I check what operating system I have?

Checking the operating system is simple, follow these 4 steps to find out.

  1. On your computers home page, click the "Start" menu. 
  2. Navigate to "My Computer" and open it. On some systems, you may have to type "Control Panel" into your "Start" menu.
  3. Select "System and Security"  and then "System"
  4. Your Windows Operating System will be displayed. (See image below)

If you have any questions, contact our support team by starting a chat with the green button on the bottom right of the page! 

Our Support team is here to help you and available M-F 7-5 MST.

Did this answer your question?